Түзу векторлық графикадағы элементерлық объекті. Линиатура icon

Түзу векторлық графикадағы элементерлық объекті. Линиатура


2. Бөлім ДӘРІСТІК КЕШЕН

Бөлім 2.1. Компьютерлік графика

Глоссарий (анықтама, сөздік);

Пиксель - cуреттің экрандық көшірмесі үшін растрдың элементарық нүктесі.

Түзу - векторлық графикадағы элементерлық объекті.

Линиатура - Растр торының жиілігі дюймдегі (lpi) сызықтар санымен өлшенеді.

RGB - RGB түстік моделі. Бұл моделде мониторлар және телевизорлар жұмыс жасайды. Үш компоненттен тұрады (қызыл, жасыл және көк).

CMYK - CMYK түстік моделі. Бұл моделді экрандық емес, басып шығаратын суреттерді жасау кезінде қолданады Төрт компоненттен тұрады (ақ, қызыл, жасыл және көк).

HSB - HSB түстік моделіКейбір графикалық редакторлар HSB түстік моделімен жұмыс жасауға мүмкіндік береді. RGB моделі – компьютерге, CMYK моделі – типографияға ыңғыйлы болса, HSB моделі – адамға ыңғайлы. Ол қарапайым және түсінікті. HSB моделінде үш компонент бар( түстің өңі, түстің қоюлығы, түстің ашықтығы).

BMP(BitMap) – Microsoft корпорациясымен жасалған Windows жүйесінде қолдануға негізделген растрлық формат.

^ PCX – PC Paint Brush, бағдарламасына арналып Zsoft фирмасымен жасалған растрлық форматтарының алғашқыларының бірі.

TIFF-(Tagged Image File Format) – Сканерленген суреттерді сақтау үшін Aldus фирмасымен арнайы жасалған.

^ PSD- Adobe PhotoShop бағдарламасының өзінің форматы.

JPEG(Join Photographic Expert Group) – бұл форматта алғаш рет суреттің сапасын кемітіп сығу принципі жүзеге асты. Ол суреттегі адамның көзіне көрінбейтін (немесе нашар көрінетін) бөліктерді өшіріп тастауға негізделеді.

^ CIF(Graphic Interchange Format) – CompuServer (бүгінгі America Online бөлімшесі) фирмасымен аумақтық желілерде растрлық суретті жіберу үшін арнайы жасалған.

CDR –CorelDraw иллюстрияциялық программасының форматы болып табылады, бірақ кезектегі версия программасына өзгертулер енгізіледі.

PDF (Portable Document Format)- әмбебап формат Adobe System фирмасында электрондық дакументті тарату үшін жасалған.

^ DCS( Desktop Color Separations ) Quark Inc компаниясы шығарған. әлемге әйгілі Xpress баспа жүйесінің жұмысы.

Move - Ерекшеленген облыстарды жылжыту құралы.

Lasso - Еркін формадағы облыстарды ерекшелеу құралдары.

^ Magic Wand - Бір түсті облысты ерекшелеу құралдары.

Crop - Суреттің шет жақтарын көрсету құралы.

Slice - Суретті фрагменттерге бөлетін құралдар.

Healing Brush - Суреттерді өңдеу құралдары.

^ Дәріс -1, 2. Компьютерлік графиканың негізгі ұғымдары.

Дәрістің мақсаты: Компьютерлік графиканың түрлерін, бағдарламаларын қарастыру.


Тақырып бойынша қарастырылатын сұрақтар:

1 Компъютерлік графика түсінігі.

2 Компьютерлік графиканың классификациясы.

3 Графиктік бейнелерді сақтау форматы.


^ Дәрістің тезисі: Бағдарламалық аппараттық есептеуіш комплекстер көмегімен суреттерді жөндеу, жасау құралдарын, әдістерін зерттейтін бөлімді–компьютерлік графика деп атаймыз. Оған адам көре алатын монитор экранындағы немесе сыртқы тасушыдағы (қағаз, кинопленка, мата т.б) көшірмелер ретіндегі адам көзбен көре алатын суреттердің барлық формалары кіреді.

Компьютерлік графиканың классификациясы. Суретті форматтау әдісіне байланысты компьютерлік графика растрлық, векторлық, фракталдық деп бөлінеді.

^ Растрық графика – суретті компьютерде нүктелер (пикселдер) жиыны ретінде көрсету форматы. Осындай суреттерге мысалға, сканерленген суреттер және сызбалар жатады.

Растрлық графика бағдарламалары: Paint, Fractal Design Painter, Corel Photo Paint, Adobe Photo Shop.

Артықшылықтары:

  • Пикселдер өлшемі кішкене болған кезде растрлық сурет жай суреттен кем көрінбейді.

  • Растрлық суреттер принтрмен оңай шығарылады.

Кемшіліктері:

  • Растрлық суреттерді сақтау үшін жадының көп көлемі қажет.

  • Растрлық суреттердің масштабталу мүмкіндіктері шектеулі, мысалы айландыру және басқадай ауыстырулар.

Векторлық графика – Сурет қарапайым геометриялық фигураларға жіктеледі- квадрат, дөңгелек, эллипс, түзу, және қисық сызық т.б.

^ Векторлық грапиканың программалары:CorelDraw, Adobe Illustrator

Артықшылықтары

  • Векторлық беине көлемді еи\мес жадыдан орын алады.

  • Векторлық бейненің сапасын жоғалтпай жеңіл түрде масштабтауға және басқасын қозғамай кез келген элементін жөндеуге болады.

Кемшіліктері:

  • Бейнені фотографикалық сапада ала алмайды.

  • Кейбір кездері қағазға басылмайды немесе қағазда онша емес болып бейнеленіледі.

^ Фрактальдық графика - Виртуалдық кеңістікте обьектілердің көлемді модельдерін құру әдістерін зерттейтін үш өлшемді (3D) графика жеке пән болып саналады.

Нүктелерден тұратын растрлық суреттер үшін ұзындық бірлігіне келетін нүктелер санын білдіретін рұқсат ету түсінігі маңызды болып табылады. Онда:

  • Түп нұсқалыққа рұқсат ету

  • Экрандық суретке рұқсат ету

  • Баспа суретке рұқсат ету

Әр түрлі форматтағы растрлық, векторлық графика әр түрлі әдіспен сақталады.Суреттің өлшемі жеке жазба ретінде сақталады, ал суреттің барлық видео пикселдерінің түсі бір үлкен деректер блокы ретінде сақталады.


Өзін - өзі бақылауға арналған тапсырмалар:
^

Қорғауға берілген реферат тақырыптары:

1. Ғылыми графика

2. Инженерлік графика


3. Іскерлік графика


Негізгі әдебиеттер /1-3/,

Қосымша әдебиеттер/8-10/.


Дәріс -3, 4. Компъютерлік графикада түстермен жұмыс істеу әдістері

Дәрістің мақсаты: Түс үлгілерін оқып үйрену.


^ Тақырып бойынша қарастырылатын сұрақтар:

1 Түс ұғымы.

2 Түс палитралары.

3 Түсті басқару жүйелері.


Дәрістің тезисі: Суреттің көріну әсерін күшейту және ондағы ақпараттың көлемін жоғарлату құралы ретінде түс компьютерлік графикада өте маңызды. Сәулелі немесе бейнелейтін обьектілерден көзге түскен жарықты талдау нәтежесінде адамның миында түсті сезу қалыптасады. Түсті сезгіш жүйкелер, әр қайсысы бір ғана түсті қабылдайтын – қызыл, жасыл немесе көк, үш топқа бөлінеді деп есептелінеді. Қай топтың болсада жұмысының бұзылуы дальтонизм – түсті теріс қабылдау, пайда болуына әкеледі.

Түстің тобы, үш <<таза >> түстердің (қызыл, жасыл, көк) және олардың туындыларының (ағылшын тілді әдебиетте RGB – Red, Green, Blue аббревиатурасын қолданады) сәулеленуі қалыптасады.

^ RGB түстік моделі. RGB моделі түсінуде өте қарапайым. Бұл моделде мониторлар және телевизорлар жұмыс жасайды. Қандай болсын өң үшін негізгі компоненттен тұрады деп есептелінеді: қызылдан, жасылдан және көктен.

^ CMYK түстік моделі. Бұл моделді экрандық емес, басып шығаратын суреттерді жасау кезінде қолданады. Олар өтпелі емес бейнеленген жарықта көрінетіндігі мен ерекшеленеді. Қағазға бояу қаншалықты көп салынас, соншалықты

^ HSB түстік моделі. Кейбір графикалық редакторлар HSB түстік моделімен жұмыс жасауға мүмкіндік береді. RGB моделі – компьютерге, CMYK моделі – типографияға ыңғыйлы болса, HSB моделі – адамға ыңғайлы. Ол қарапайым және түсінікті. HSB моделінде үш компонент бар: түстің өңі, түстің қоюлығы, түстің ашықтығы. Бұл үш компонентті басқара отырып қалған екі моделмен жұмыс жасағандағыдай көп түс алуға болады.

Түстік палитра – бұл түс қандай кодпен кодталғаны туралы ақпарат сақталатын деректер кестесі. Бұл кесте графикалық файлмен қатар жасалады және сақталады

Компьютер үшін түстік кодтаудың ең ыңғайлы әдісі – 24 разрядты True Color. Бұл режімде түстік құрауыштарын R (Қызылды), G (Жасылды), B (Көкті) кодтауға бір байттан бөледі. Әр құрауыштың ашықтығы 0 – 255 ке дейінгі санмен анықталады және 16,5 миллион түстің қайсы бірі болсын компьютер 3 код бойынша шығарады. Бұл жағдайда түстік палитра қажет емес. Себебі 3 байттың ішінде пикселдің өңі туралы жеткілікті дерек сақталады.

Түстерді сәйкестіру үшін компьютерлік графиканың жөндеу қадамдарында түстерді басқару жүйесі қолданылады. (Color Management System – CMS).Бұндай жүйелерде түстік деректермен алмасу кезінде барлық құрылғыларға қажетті обьективті параметрлер жиыны бар.


Өзін - өзі бақылауға арналған тапсырмалар:
^

Қорғауға берілген реферат тақырыптары:

1. Түсті сипаттау әдістері


2. Грассман заңы

3. Гетенің табиғи түстер шеңбері


Негізгі әдебиеттер /1-3/,

Қосымша әдебиеттер/8-10/.


Дәріс - 5,6,7. Corel Draw бағдарламасы жайлы түсінік

Дәрістің мақсаты: CorelDraw бағдарламасының ерекшеліктерін студенттерге таныстыру.

^ Тақырып бойынша қарастырылатын сұрақтар:

1 CorelDraw бағдарламасына түсінік.

2 CorelDraw бағдарламасының артықшылықтары.

3 CorelDraw бағдарламасын пайдалану ортасы.


^ Дәрістің тезисі: Corel Draw суреттік графика жұмысына арналған интеграцияланған объектілі – бағытталған бағдарламалар пакетін құрайды.

«Біріккен кешен» ұғымын былай түсінуге болады. Corel Draw 9 әр түрлі көптеген міндеттерді шешуге бағытталған бағдарламалардың кешенін құрайды. Бірігуін мына мағынада түсіну керек: бұған кіретін бағдарламалар мәліметтермен жеңіл алмаса немесе әр түрлі әрекеттерді сол және басқа да мәліметтермен бірізділікпен орындай алады.

Біздің дәрістер курсымыз Corel Draw суреттерді дайындау бағдарламасы-қуатты пакеттің бір ғана құрылымына арналған.

Суретті графика машиналық графиканың қолданбалы тармағын құрайды. Суретті графика аймағына суреттер, жарнамалық хабарламалар, қыстырмалар және т.б көркем өнімдер деп атауға болатындардың бәрі жатады. Суретті графиканың объектілері басқа қолданбалы объектілерден өзінің алғашқылығы мен ерекшеленеді – олар суретшінің немесе дизайнердің қатысуынсыз автоматты түрде кейбір бастапқы мәліметтермен құрыла алмайды. Олардан айырмашылығы диаграммалар (іскерлік графика), сызбалар (инженерлік графика), функцияның графикасы (ғылыми графика) сияқты графикалық тәсілін ұсынады.

«Объектілі-бағытталған» терминін мына мағынада түсіну керек, бейнені құру және өзгерту үрдісінде орындалатын барлық операцияларды, қолданушы бейненің семантикалық-жүктелген элементтер-объектілермен жүргізеді.

Екінші ерекшелігі мынада: объектілердің әр стандартты кластарына сәйкесінше басқарушы параметрлердіғң немесе кластардың атрибуттарының бірегей жиынтығы қойылады.

Үшінші ерекшелігі мынада: Объектілердің әр стандартты кластарына стандартты операциялардың тізімі анықталған. Corel Draw 9-тың объектілі-бағыты қолданушыға жұмыста шексіз икемділік береді. Бейненің жеке объектілерді ерекшелеуге және жұмыстың кез-келген кезеңінде өзгертуге болады.


Өзін - өзі бақылауға арналған тапсырмалар:

Қорғауға берілген реферат тақырыптары:

  1. CorelDraw бағдарламасында жұмыс жасау.

  2. CorelDraw бағдарламасында құралдары.

  3. CorelDraw бағдарламасында мәтіндермен жұмыс.


Негізгі әдебиеттер /2/,

Қосымша әдебиеттер/4,10/.


Дәріс–8,9,10. Corel draw бағдарламасының жұмыс ортасы

Дәрістің мақсаты: CorelDraw бағдарламасының интерфейсін қарастыру.

^ Тақырып бойынша қарастырылатын сұрақтар:

1 CorelDraw бағдарламасына кіру жолдары.

2 CorelDraw бағдарламасының басты элементтері.

3 CorelDraw бағдарламасының құралдар тақтасы.


^ Дәрістің тезисі: Бағдарламаны іске қосқаннан кейін экранда Corel Draw қолданушы интерфейсінің басты элементтерімен негізгі терезесі ашылады (1-сурет).




1-сурет. Corel Draw 9 терезесі.


Windows стандарттарына сәйкес тақырып жолының астында меню өте күрделі, яғни саны көп меню ішіндегі менюлер мен командалар. Жұмыс кеңістігінің сол жақ бөлімінде жұмыс тәртібін (режим) таңдауға арналған элемент интерфейсі-құралдар тақтасы (Toolbox) орналасқан. Таңдау тәртібі құралдар тақтасындағы кез-келген батырмаға тышқанға шерту арқылы орындалады.

Құралдардың кейбір батырмаларының төменгі оң жақ бұрышынд үшбұрыш жабдықталған, ол дегеніміз бұл батырмамен бірнеше құралдар байланыстылығын көрсетеді.

Меню жолынан кейін құралдық жол (Toolbars) орналасу мүмкін. Кез-келген құралдық жол тәуелсіз тақта түрінде экранның кез-келген жерінде еркін жағдайда да болуы мүмкін.

Ол үшін жолақтың сол жақ бөлігіндегі аймақты екі сызықпен басып алып және сәйкес тақырыппен тақта түрін алған жолды орналастыру қажет. Қайтадан жолға айналдыру үшін тақырыпты басып алып және оны жоғары орналастыру керек.

Сол және басқа жолдарды шығару Windows (Терезе) менюі Toolbars (Құралдық жолдар) командасы арқылы шақырылатын Options (Параметрлер) диалог терезесіндегі Customize (Баптау) бөлімінде қамтамасыз етіледі.

Стандартты құралдар тақтасында (Standart) файлдарды ашуға, файлдарды ашуға, файлдарды сақтауға, алмасу буфері жүйелерінің операциялары және т.б сәйкес жиі орындалатын командалар-басқару элементтері орналасқан.

Стандартты тақтадан төмен Атрибуттар тақтасы (Property Bar) немесе қасиеттер тақтасы орналасқан. Ол ерекшеленген объектінің және стандартты операциялардың басқару параметрлеріне сәйкес келетін, оларды таңдалған құралдың көмегімен орындауға болатын барлық басқару элементтерінің жиынтығын ұсынады.

Corel Draw терезесінің төменгі бөлігінде қалып-күй жолы (Status Bar) бар. Онда жұмыс үрдісіндегі ерекшеленген объект жайлы мәліметтер шығады. Жұмыс кеңістігінде суреттеме орналасатын баспа бетінің бейнесі көрініп тұр.

Көлденең орналасқан айналдыру жолағының сол жағында беттен бетке көшуге болатын, беттің атымен аталған батырмалар мен таңбашалар, яғни навигатор деп аталатын басқару элементі орналасқан.

Айналдыру жолақтары, координаталық сызғыштар (координаталарды өлшеу үшін). Түйісілетін терезе (Dockers) ерекше роль атқарады. Докерлер бағдарламасының функциясына кіруді қамтамасыз етеді. Әр түрлі міндеттер үшін әр түрлі докерлер арналған, олар оннан астам. Оларды қажет кезінде ашады.

Өзін - өзі бақылауға арналған тапсырмалар:

Қорғауға берілген реферат тақырыптары:

  1. Қисық (CURVE) тобының құралдары

  2. Векторлық әсерлер.

  3. Құжатты ұйымдастыру


Негізгі әдебиеттер /2/,

Қосымша әдебиеттер/4,10/.


Дәріс–11,12,13. Coreldraw бағдарламасы жұмысының негізгі тәсілдері

Дәрістің мақсаты: CorelDraw бағдарламасы жұмысының тәсілдерін уйрену.

^ Тақырып бойынша қарастырылатын сұрақтар:

1 CorelDraw бағдарламасында примитивтерді салу тәсілдері.

2 CorelDraw бағдарламасында объектілерді құру.

3 CorelDraw бағдарламасында құралдардың режимдері.


^ Дәрістің тезисі:


Тіктөртбұрыш салу тәсілдері:

  1. Құралдар тақтасындағы Rectangle (Тіктөртбұрыш) құралын белсенді етеміз.

  2. Контекстік менюден Create Object → Rectangle (Объекті құру→ Тіктөртбұрыш) командасын таңдап беттің бос жеріне тышқанның оң жағын шертеміз.

  3. F6 батырмасын бас.

^ Модификатор –батырмасы. Егер тіктөртбұрыш салу кезінде CTRL батырмасын басып тұрсақ тұрғызылған объекті басқарудан тәуелсәз квадратты болып қалады.

Егер тасымалдау кезінде SHIFT батырмасын басып тұрсақ онда тіктөртбұрыш бұрышынан емес ортасынан бастап салынады.

Екі модификаторды да бір кезде қолдануға болады, егер Rectangle (Тіктөртбұрыш) көрсеткіш құралын салу керек кезінде бір мезетте CTRL және SHIFT батырмасын басып тұрсақ онда квадрат ортасынан бастап салынады.

Объектілерді құру

Құралдар

  • Тіктөртбұрыш

  • Эллипс

  • Спираль

  • Көпбұрыш

  • Жұлдызшa

  • Қисық (сызықты тышқанның жүргізілуімен салады)

    • Қисық безье (басқарушы нүктелер суретпен сызықты салады).

    • Құралдар қисық түзу сияқты объектілерді салады.

Artistic Media (Cупер құрал) құралы үзіліс қалдықтағы қисық сызық сияқты жике бойында объектілерді салады (бояу жаққыш немесе қылқаламмен жұмыс істейді). Бұл құралдардың көмегімен салынғанда Форма құралындағы нүктелер арқылы тасымалдап өзгертуге болады.

Сол бөліктегі атрибуттар жолында пиктаграмма батырма түрінде берілген құралдардың бес режимі бар.

Бірінші батырма –Preset (Дайындау) режимі. Бұл режимде дайын үлгіде өзінің жуандығын өзгертетін объектілерді құруды қамтамассыз етеді. Атрибуттар жолында жасырын меню Preset Stroke List (Штрихталған тізім дайындау) үлгісі берілген терезенің алдыңғы жағында штрихтың максималды енін (диапозоны 0,764 тен 254 мм.дейін) беретін Artistic Media Tool Width(Құрал ені) жол үлгісі орналасқан. Сол жақта Freehand Smoothing( Қисық түзету) алаңды түзетеді. Диапозоны 0 ден 100 дейін.

^ Екінші батырма –Brush(Қылқалам) режимі. Бұл режим мәтін және күрделі немесе еркін түрдегі сәндәк тағымдарды құрауды қамтамассыз етеді. Параметр режимдері: Freehand Smoothing( Қисық түзету) Tool Width(Қалыңдығы), Brush Stroke List (Қылқалам пішіні); Save (Сақтау) батырмасы объектідегі сапалы қылқаламды сақтайды. Delete(Жою) кнопкасы тізімдегі кез келген нұсқаны жояды.

Үшінші батырма –Sprayer(Объектілерді шашқыш) режимі. Бұл режимде атрибуттан соң оның параметрлерін басқаратын батырмалар бар.

^ Төртінші батырма – Атривуттар тақтасындағы Artistic Media (Супер құрал) Calligraphic(Көркем жазу) режимі.Бұл режимде анықталған кең бояу жаққыш немесе қауырсынмен сурет салады. Атривуттар тақтасында жаңа параметрлер пайда болады, Олар төмендегідей:

  • Freehand Smoothing( Қисық түзету)

  • Width(Құрал ені) - максималды штрих өлшемінен 0,762 ден 254мм- ге дейін береді.

  • Angel (Бұрыш) –қауырсынның иілген бұрышын анықтайды.

Бесінші батырма- Artistic Media (Супер құрал) атрибут құрал тақтасында Preeure(Басып жазу). Пернетақтада рекше пернелер комбинация ықпалымен өзінің жуандығын өзгертетін мәндері 0,762 ден 254мм- ге дейінгі штрихтарды құрайды. Бұл режимнің параметрі Freehand Smoothing( Қисық түзету) және Width(Құрал ені).

Супер құрал кез келген экрандағы жиек параметрін түзетеді. Ол үшін экранға Dockers тақтасындағы Artistic Media (Супер құрал) құралын шақырамыз. Ол Effects(Эффект) менюі немесе Windows-Dockers (Терезе- Docker тақтасы) менюі шақырылады. Панел екі бөліктен тұрады. Last Used(Қолдану ) және Default Strokes(Қор жиынтық).

Өзін - өзі бақылауға арналған тапсырмалар:

Қорғауға берілген реферат тақырыптары:

  1. Құю және құрсау (обводка) параметрлері

  2. CorelDraw бағдарламасында қабаттармен жұмыс.

  3. CorelDraw бағдарламасында стилдер.


Негізгі әдебиеттер /2/,

Қосымша әдебиеттер/4,10/.


Дәріс: 14,15,16. Adobe Photoshop бағдарламасының ерекшеліктері

^ Дәрістің мақсаты: Adobe PhotoShop бағдарламасының ерекшеліктерін студенттерге таныстыру.


Тақырып бойынша қарастырылатын сұрақтар:

1 Adobe PhotoShop бағдарламасына түсінік.

2 Adobe PhotoShop бағдарламасының артықшылықтары.

3 Adobe PhotoShop жұмысының негізгі тәсілдері.


^ Дәрістің тезисі: Пакеттердің әйгілі мүмкіншіліктері кеңейтілген және жаңа пакеттер қосылған.

  1. PhotoShop және Image Ready құрамына тез қарап шығу және суреттер тобын басқару модулі енген. Алғашында басқадай жасаушылардың утилиталары қажет болған, мысалы ACDSee немесе ThumbsPluse.

  2. WBMP форматындағы, қалтаға салатын компьютерлерде (PDA) қолданылатын инфорт және экспорт филтрі қосылған. Бұл форматтың қатаң шектеулерін ескере отырып суретті оптимилизациялау автоматты түрде жүріледі, сонымен қатар суреттің сапасын ең ...... мөлшерде кемітеді.

  3. Бірнеше суреттерді немесе суреттің көшірмелерін бір параққа қоятын құрал пайда болды. Оның сыртында бұл құралды суреттерде алдын ала миниатюр ретінде көруге мүмкіндік беретін Web галерияларды жасауда қолданады.

  4. PhotoShop 7 ге алғаш рет топтасып жұмыстауға арналған құралдар енді<<каробколық>> версиясының құрамына әр түрлі қолданушылардың барлық Adobe өнімдеріне қатынауды қамтамасыз ететін After Cast серверлік кеңейтілуі енді, егер қолданушының біреуі файлға өзгеріс енгізссе онымен бірге жұмыс істейтін адамдардың барлығы оны көреді. Бірақ After Cast баптау жүйелік админстратордың жұмысы, сондықтан PhotoShopты үйде ғана қолданатын адамдар бұл құралмен таныс емес.

  5. Кисть (аэрограф) баптауының 12 параметірі бар. Бұл алдыңғы версиясына қарағанда 3 есе көп. Бұл дәстүрлі сурет (живопис) салу құралдарын нағыз түрде жасай алады. Шаблон ретінде әр түрлі растрлық суреттер қолданылады. Суреттің прагменттері негізінде текстура жасау құралдары жетілген.

  6. Healing Brush жаңа құралы пайда болды. Оны Clone Stamp құралының жетілдірілген түрі ретінде немесе суреттің бетіндегі әр түрлі артефактерды жоғалту құралы ретінде қолдануға болады. Бұл жағдайда жарықкөлеңке ойыны және түп нұсқаның текстура суреті толығымен сақталады. Жасаушылар Healing Brush құралын портреттік суреттердегі шаң басқанда кішкене жарақаттарды сондай-ақ, әжімді, меңдерді жасыруға қолдануды ұсынады.

  7. Сырттай түскен жарықты жасыруға болатын AutoСolor құралы қосылды. Бұл құралды қолдану сандық және қарапайым камераклармен жасанды жарық кезінде алынған суреттерді жөндеуді жеңілдетеді. Сканерленген негативтерден маскаларды өшіру кезінде AutoСolor жақсы нәтиже береді. PhotoShop құрамына алғаш рет дұрыс жазуды тексеру құралы енді.

  8. Web гарафикамен жұмыс жасауға арналған Image Ready бағджарламасы жаңарды. Image Ready-де анимацияларды басқару өзгерген. Сондықтан алғашқы версияларына қарағанда қарапайым болады. Интернетке тараеуға арналған графиктерді оптимилизациялау құралдары жетілдірді. Бұрын бұл модуль жұмысы сынау обьектісі болған және Web мастерлерге басқа фирмалардың өнімдерін қолдануға тура келеді. PhotoShop және Image Ready <<шығу кезінде >> қарсылас бағдарламалық өнімдер жөндеуге файлдарының көлемінен көп айырмашылық жоқ файлдарды береді.


Өзін - өзі бақылауға арналған тапсырмалар:

Қорғауға берілген реферат тақырыптары:

  1. Abode PhotoShop бағдарламасын қолдану технологиясы.

  2. Суретті өңдеу әдістері.


Негізгі әдебиеттер /3/,

Қосымша әдебиеттер/7-9/.


Дәріс: 17,18,19. Photoshop бағдарламасының жұмыс ортасы

^ Дәрістің мақсаты: Adobe PhotoShop бағдарламасының интерфейсін қарастыру.

Тақырып бойынша қарастырылатын сұрақтар:

1 Adobe PhotoShop бағдарламасына кіру жолдары.

2 Adobe PhotoShop бағдарламасының басты элементтері.

3 Adobe PhotoShop құралдар тақтасы.


^ Дәрістің тезисі: 2-суретте жұмыс жасау кезіндегі экран бейнесі көрсетілген.






Сурет 2 PhotoShop экранының бейнесі


Меню жолы

  • File меню

File менюндегі командалар жасау, ашу, орналастыру, жабу, сақтау, сканерлеу, инпорттау немесе экспорттау, суретті басып шығару, файлды желіден жіберу, кйебір операцияларды автоматтандыру және PhotoShopтан шығу кезінде қолданады. File > Jump to (Файл >Өту) менюн қолдану Image Ready немесе Colive сияқты көмекші қосымшаларға көшу үшін қолданамыз.

  • Edit меню

Edit (Түзету) менюнде суретті түзететін командалар орналасқан: көшіру, трансформациялау, енгізу және суреттің түсін анықтау сондай-ақ анықталған формасы және өлшемі бар кистіні жасау командалары. Менюдегі Fade (Әлсірету) командасы көптеген операциялар (мысалы, сүзгінің соңғы қолдануы, басқадай құралмен сурет салу және түзету командасы) әсерін әлсіретеді. Purge (Тазалау) командасы жадыны босатады. Сондай – ақ Edit меню көмегімен Color Settings (Түсті сипаттау), Preset Manager (Баптау менежрі) және Preferences (Орнатулар) сұхбаттық терезелерін ашуға болады.

  • Image меню

Image (Сурет) менюнің Mode (Режим) командасының көмегімен сурет 8 ұсыныстың біреуіне айлануы мүмкін. Adjustments (Түзету) командасымен түсті қоюлықты, түстің ашықтығын және суреттің қараңғылығын өзгертеді. Image Size (Суреттің өлшемі) командасының көмегімен файлдың өлшемін, суреттің өлшемін немесе рұқсат етуін өзгертуге болады. Canvas Size (Холст өлшемі) сурет орналасқан жұмыс кеңістігінің өлшемін өзгерту кезінде қолданылады.

  • Layer меню

Layer (Қабат) менюнде орналасқан командалар Step – тегі қабаттар ретін өзгертуге, топталғандарды өшіруге, көшіруге, қосуға, бір бірімен байланысқан қабаттардың орналасуын меңгеруге, қабаттарды біріктіруге оларға маск қосуға және суретті жалғыз қабатқа өзгертуге мүмкіндік береді. Layers палитрасының менюін қолданып кейбір командаларға жылдам қатынауға болады.

  • Select меню

Select (Ерекшелеу) менюнің All (Барлық) командасы қабатты бүтіндей ерекшелейді. DeSelect (Ерекшелеуді алып тастау) командасы керісінше бұрын ерекшеленген облыстардың бұрын ерекшеленуін алып тастайды. ReSelect (Ерекшелеуді қалпына келтіру) командасы DeSelect командасы соңғы рет қолданған облысты қайтадан ерекшелейді. Color Range (Түстер диапозоны) түстерді ескеріп ерекшелейді. Бұл менюдің басқа командалары ерекшеленген облыс шекарасын сығады, біртектендіреді, сондай – ақ ерекшеленген облыстарды арналарға сақтайды немесе арналардан жүктейді.

  • Filter меню

Filter (Сүзгі) құрамында суретті редактрлейтін кең диапозонды операцияларды орындайтын сүзгілер бар. Dig mark (Диджимак) сүзгісі суреттің бетінен адамның көзіне көрінбейтін авторлық құқықтың белгісін қояды.

Бағдарламаның алдыңғы версиясына қарағанда бұл менюге Image менюнен екі команда қосқан. Extract (Шығару) командасы күрделі формадағы ерекшеленген облыстарды жасауға мүмкіндік береді. Liquefy (Бұрмалау) суреттің нүктелерін бір бағытқа жылжытады.

  • View меню

View (Түр) меню командалары экранда не бейнеленіп, не бейнеленбей тұрғанын бақылайды. Camut Warning (Гамма туралы ескерту) төрт түсті басып шығару кезінде көрінбей қалатын түстерді ерекшелейді. Proof Setup (Басып шығаратын суретті тарылту) командасы сурет әр түрлі басып шығару режимінде қалай көрінетінінбайқауға мүмкіндік береді. View менюнің басқа командалары суреттің масштабын басқарады сондай-ақ экранға сызғыштарды, координаталық торды, сурет бөлінген қосымша сызықтарды және облыстарды шығарады.

  • Window меню

Window (Терезе) менюнің командалары әр түрлі палитраларды Көрсету/Жасыруды басқарады. Бұл менюде сондай-ақ біреуін активтендіруге болатын ашылған суреттердің тізімі орналасқан.

Windows операциялық жүйесі ортасында жұмыс істеу кезінде суреттердің терезесінің орналасуын басқаруға және қалып күй жолағын Көрсетіп/Жасыруға мүмкіндік береді.

  • Help меню

Help (Көмек) менюнің командалары PhotoShop бағдарламасының интерактивті режиміне қатынауға, Adobe компаниясының соңғы жаңалықтарын білуге, Adobe Online сайтына кіруге немесе экранда орындалатын бір қимылды орындауға көмектеседі.

Құралдар панелі. Пиктограммасы экранда көрініп тұрған құралды активтендіру үшін оның пиктограммасына шертіңіз. Кейбір пиктограммалардың жанында кішкентай бағыт белгісі орналасқан. Оған шерткен кезде сол топқа кіретін құралды таңдап алуға болатын қалқып шығатын палитра ашылады.

Пернетақта көмегімен құралдарды шақыру өте ыңғайлы. Егер сіз пернелер комбинациясын ұмытып қалсаңыз курсорды құралдың пиктограммасына апарып бірнеше секунт күте тұрсаңыз қалқып шығатын мәтін оны есіңізге түсіреді. Пиктограммасы жасырылған бір топқа кіретін құралдарды кезектеп шақыру үшін Shift пернесін және сәйкес келетін <<ыстық>> пернені басыңыз. Сондай-ақ Alt пернесін басып тұрып көрініп тұрған құралдың пиктограммасына шертуге болады.


Өзін - өзі бақылауға арналған тапсырмалар:

Қорғауға берілген реферат тақырыптары:

  1. Adobe PhotoShop бағдарламасының ыстық пернелері.

  2. Палитралар.

  3. Adobe PhotoShop-да бейнелерді құру әдістері


Негізгі әдебиеттер /3/,

Қосымша әдебиеттер/7-9/.


Дәріс: 20,21,22. Photoshop бағдарламасы жұмысының негізгі тәсілдері

Дәрістің мақсаты: Adobe PhotoShop бағдарламасының жұмысының тәсілдерін уйрену.

^ Тақырып бойынша қарастырылатын сұрақтар:

1 Adobe PhotoShop бағдарламасында палитралар.

2 Adobe PhotoShop бағдарламасының басты әдістері.

3 Adobe PhotoShop бағдарламасының параметрлерін баптау.


^ Дәрістің тезисі: Соңғы операцияны болдырмау үшін Edit>Undo (Түзету>Болдырмау) командасын немесе Ctrl+Z пернелерін қолданыңыз. Кейбір командаларды болдырмауды болмайтынын ескеріңіз. Бірнеше қадамдарды болдырмау үшін History палитрасындағы алдыңғы оқиғаға шертіңіз немесе History Brush құрал көмегімен суреттің анықталған облыстарын қалпына келтіріңіз.

  • History палитрасындағы Create new snap shot (Сурет тарту) батырмасына суреттің верцияларын сақтау үшін периодты түрде шертіңіз. Егер сіз суреттің сәйкес версиясына қайтқыңыз келсе жасалған суреттің миниатюрасына шертіңіз.

  • Әр түрлі түстермен тәжірибе жасау үшін түзетілетін қабатты қолданыңыз, одан кейін түзетілген қабатты астыңғы қабатпен біріктіріңіз. Осылайша алынған әсерді сақтаңыз немесе түзетілген қабатты өшіріп тастаңыз. Layers палитрасында орналасқан Opacity (Мөлдірсіз) жылжытқышы көмегімен түзетілетін қабаттың қолдану әсерін әлсіретуге болады. Түзетілетін қабаттың әсерін шектеу үшін оның астындағы қабатты қосатын (clipping group) тобын жасаңыз.

  • Edit>Fade (Түзету>Әлсірету) командасы немесе Ctrl+Shift+F батырмалар көмегімен сүзгінің соңғы қолдану әсерін әлсіретуге болады, түзету немесе қайталау әрекеті немесе болдырмау командаларын қолданусыз түзету құралы; Fade командасы орындалу кезінде өзіңізге қажетті араластыру режімін және мөлдірсіз деңгейін таңдаңыз.

  • Фильтр немесе команданы қолданудан кейінгі экранның қайта сызылуын тоқтату үшін басқа құрал немесе команданы (орындалу индикаторы көрініп тұрған кездегі команданы болдырмау үшін Esc басыңыз) таңдаңыз.

  • Суреттің сапасының талаптарына сәйкес келетін суреттің өлшемін және мүмкінінше ең аз шешілуін таңдаңыз. Әрекеттің қолданылған командаларын сақтай отырып ең төменгі шешілуі бар суреттің үлгісін жасауға болады, одан кейін бұл сурет үшін жоғары шешілуі бар әрекет жасауға болады. Векторлық қабаттарда (түзетілетінін мәтінін және фигураның қабаты)басып шыққан кезінде құжаттың шешілуі емес басып шығаратын құрылғының шешілуі болады.

  • Масштабын үнемі өзгертпес үшін суретті бір үлкен, бір кішкене екі терезеден көрсетіңіз.

  • Ерекшеленген күрделі облыстарды арнайы жарты өңді (альфа-арналар (alpha-channel) деп аталатын), оларды қай кездеде жүктеу және қандайда бір суреттерде қолдануға болады. Немесе, контур немесе қиятын контур жасаңыз – олар альфа арналардан қарағанда дискден аз ғана орын алады. Артынан оларды ерекшеленген облыстың шекарасына айландыруға болады.

  • Ерекшеленген облысты, суреттің қорғалған облысын көрсететін, ал қорғалмаған облысын жасыратын, маскге айландыру үшін Quick Mask (Жылдам маск) режімін қолданыңыз, одан кейін сурет салу құралымен маскның формасын өзгертуге болады. Егер тұйықталған облысты қайтадан ерекшеленген облысқа айландырғыңыз келсе Quick Mask режімін қосыңыз.

  • CMYK файлдары RGB файлдарына қарағанда жайырақ өңделетін болғандықтан, суретті алдын ала CMYK режімінде көру мүмкіндігі болу үшін, Proof Setup Working CMYK (Байқап көру таңбасын тарылту>Жұмыс CMYK ) командасын қолданыңыз. Суретпен жұмыс аяқталу кезінде оны CMYK типтің толық ұсынуына айналдырыңыз.

  • <<Ыстық>> пернелерді көбірек еске сақтаңыз. Үйренуді құралдарды таңдаудың <<ыстық>> пернелерден бастаңыз. Анықтама ретінде қалқып шығатын мәтінді қолданыңыз немесе <<ыстық>> пернелер тізімін қараңыз.

  • PhotoShop бағдарламасының жұмысы үшін 60МВ-тан кіші емес немесе құжаттың өлшемінен 4 есе көп оперативті жады бөлуге тырысыңыз.

  • Edit>Purge (Түзету>Тазалау) командасын Clipboard (Алмасу буфері), Undo (Қайтару) командасымен, History (Тарих) палитрасымен немесе аталғандардың барлығымен All (Барлығы) жұмыс жасауға бөлінген оперативті жадын босату үшін қолданыңыз. Purge командасын қайтаруға болмайды.
^

Параметрлерді баптау

Баптаудың сұхбаттық терезесі Түзету>Баптаулар немесе Ctrl+K пернелер командасымен шақырылады.

General (Басқы): палитраны шығару, түсініктеме мәтінді шығару.


  1. Сақтау

  2. Display & Cursor (Бейнелеу және Курсор)

  3. Transparency & Gamut (Тордың өлшемі, тордың түстері)

  4. Units & Rulers (Өлшеу бірліктері және Сызғыштар)

  5. Guides & Grid (Бағыттауыштар және Тор) суреттің элементтерін тегістеу командалары.

Өзін - өзі бақылауға арналған тапсырмалар:

Қорғауға берілген реферат тақырыптары:

  1. Adobe PhotoShop бағдарламасында қабаттармен жұмыс.

  2. Бейнелердің түсін өзгерту амалдары.

  3. Adobe PhotoShop-да бейнелерді трансформациялау


Негізгі әдебиеттер /3/,

Қосымша әдебиеттер/7-9/.

^

Дәріс: 23,24. Үш өлшемді графиканың негізгі түсініктері


Дәрістің мақсаты: Үш өлшемді графиканың ерекшеліктерін студенттерге таныстыру.

^ Тақырып бойынша қарастырылатын сұрақтар:

1 Үш өлшемді графика туралы түсінік.

2 Үш өлшемді графиканың артықшылықтары.

3 Үш өлшемді графиканың бағдарламалық құралдары.

Дәрістің тезисі: Үш өлшемді графика ғылыми есептеулер, инженерлік жобалау және физикалық объектілерді компьютерде үлгілеу облыстарында кең таралған. Мысал ретінде үш өлшемді үлгілеудің күрделі нұсқасын - физикалық дененің қозғалатын суретін жасауды қарастыру.


- объектінің шынайы формасына сәйкес келетін виртуалды каркасын (қанқа) жобалау және жасау;

- шынайы физикалық қасиеттері бойынша материалдарға ұқсас виртуалды материалдарды жазу және жобалау;

- объектінің әртүрлі сыртқы бөліктеріне материалдарды меншіктеу;

- объекті әрекет ететін кеңістіктің физикалық параметрлерін баптау– жарық шашу, бет және өзара әрекеттесетін объектілердің қасиеттері;

- объектінің қимылдау жолын беру;

- нәтиже беретін кадрлар қатарын есептеу;

- нәтижесінде шығатын анимациялық рөлге әсерлерді енгізу.

Объектілердің шынайы үлгісін жасау үшін геометриялық фигуралар (тіктөртбұрыш, шар, куб т.б.) және сплайндық бет деп аталатын тегістер қолданылады. Соңғы жағдайда тең өлшемді емес тордағы бикубикалық рациональды В-сплайндар (NURBS) әдісі жиі қолданылады. Мұнда беттің түрі кеңістікте орналасқан демеу нүктелер торымен анықталады. Әр нүктеге, нүктенің жақын өтетін кеңістіктің бөлігіне әсер ету деңгейін анықтайтын коэффициент меншіктеледі. Нүкелердің орналасуының және коэффициенттер өлшемінен кеңістік формасы және «тегістігі» тәуелді болады. Объектінің «қанқасы» құрылып болғаннан кейін оның бетін материалдармен жабу керек. Компьютерлік үлгілеуде қасиеттердің барлығы беттің көрінуіне арналады, яғни беттің мөлдірлік коэффициентін есептеуге, материалдың шекарасында және қоршаған кеңістікте жарықтың сәулесін сындыруды есептеуге. Бетті бояу Гуро (Ground) немесе Фонга (Phong) әдістермен жүзеге асады. Бірінші жағдайда фигураның түсі оның төбесінде ғана есептелінеді, одан кейін беті бойынша сызықты түрде жойылады. Екінші жағдайда объектіге нормаль құрылады, оның векторы құрауыш фигуралардың бетімен жойылады және әр нүктенің жарықтануы есептелінеді.

Үш өлшемді графиканың бағдарламалық құралдары. Үш өлшемді графиканы дербес компьютерде өндейтін бағдарламалық құралды үш пакет құрайды. Олар Windows операциялық жүйесімен басқарылатын машиналар нәтижесінде жұмыс жасайды.


  1. Kіnetix фирмасының 3D Studio Max бағдарламасы.

Бастауында Windows платформасы үшін жасалынған. Бұл пакет «жарты маманды» деп саналған. Пакеттің ерекше қасиеттері үш өлшемді графиканың тездету аппаратарының көп санын қолдау, қуатты жарықтық әсерлер, сырттай фирмаларымен қосымшалардың көп жасалуы болып табылады. Аппараттық ресурстарға қойылатын талап төмен болғандықтан орта деңгейлі компьютермен жұмыс жасауға мүмкіндік береді. Бұл пакеттің көмегімен «Звездный Война» фильмінің анимациялық кадрлері жасалынған.

  1. Microsoft компаниясының Softimage 3D бағдарламасы.

Бастауында SGI жұмыс станциялары үшін жасалған және жуырдан бастап Windows NT операциялық жүйесіне арналып өзгерді. Бағдарлама үлгілеудің көп мүмкіндіктерімен, физикалық және книматографикалық параметрлерді басқарудың көп санымен ерекшелінеді. Рендеринг үшін сапалы және жылдам Mental Ray үлгісі қолданылады. SGI арнайы графикалық станция әлемінде бұл бағдарлама «де - факто» стандарты болып есептелінеді, IBM PC платформасында салмақты болып көрінеді және қуатты аппараттық ресурстарды талап етеді. Тұйық пакет, ақпарат тек ағылшын тіліне ғана, Россияда тек 2002 жылы пайда болды. «Прогулки с динозаврами» фильмі жасалынған.

  1. Мүмкіндіктер және интерфейс тұрғысынан революциялық болып әйгілі компаниялардың (Alias, Wavefront, TDI) консорцимымен жасалған Maya бағдарламасы.

Пакеттің әртүрлі операциялық жүйеге соның ішінде Windows NT арналған нұсқалары бар, ол үлгілеуден құрылған және келесі бөліктерден тұрады:

- Base – бағдарламаның ядросынан тұрады. Үлгілеудің негізгі құралдарын, инверстік книматиканы, дыбысты жөндеу, физикалық қатты денелердің бейнесін жасау, қимылды рендерингді және әсерлердің негізгі жиынын басып алуды қолдайды.

- Maya F\X – бөлшектердің жүйесін және жұмсақ денелердің ара қатынасу физикасын үлгілеуді жөндеу әсерлерін қолдайтын қосымша үлгілердің жиыны.

- Maya Power Modeler- объектілердің полиногольды және сплайндық үлгілеуінің қуатты құралдарынан тұрады.

- Maya Artisan- виртуалды үлгіні мүсінші және суретшілердің шынайы жұмысына тән әдіспен жөндеуге мүмкіндік беретін алдынғы модуль. Мысалы объектінің бетіне “кистімен” сурет салуға, бетті тегістеп немесе “мүмкін кескіштермен” кедір-бұдырлы қалдырмауға мүмкіндік береді.

- Maya Cloth- киімді үлгілеуге арналған.

- Maya Fur- жүнмен жабылған беттерді немесе аң терісін бейнелеуге арналған модуль.

- Maya Live- шынайы съемкаларды компьютерлік анимациялармен байланыстыратын сценариялық модуль. Maya құралдары төрт топқа бөлінген: Animation (анимация), Modeling (үлгілеу), Dynamic (физикалық үлгілеу), Rendering (визуализация). Ыңғайлы бапталатын интерфейс заманның талабына сай орындалады. Бүгінгі күні үш өлшемді графиканың дербес компьютері үшін өндеу және жасау құралдарының класының ішінде алдыңғы пакет болып табылады.


Өзін - өзі бақылауға арналған тапсырмалар:

Қорғауға берілген реферат тақырыптары:

      1. Жарықтандыру модельдері.

      2. Көлеңкелерді құрастыру әдістері.

      3. Рендеринг.


Негізгі әдебиеттер /1/,

Қосымша әдебиеттер/5,6,8/.

^

Дәріс – 25,26,27. 3D max интерфейсінің негізгі элементтері


Дәрістің мақсаты: 3D Studio Max бағдарламасының интерфейсін қарастыру.


Тақырып бойынша қарастырылатын сұрақтар:

1 3 өлшемді – графиканың бағдарламалық құралдары.

2 3D MAX интерфейсінің негізгі элементтері.
^

3 МАХ 2.5 объектілері.



Дәрістің тезисі: Сурет 3-де 3D Studio Max 5 жұмыс жасау кезіндегі экран бейнесі көрсетілген.



Сурет 3 3D Studio Max 5 экран бейнесі


^ Проекция терезесі. Мах көрінісінің барлық объектісі аумақты (World) координаталар жүйесінде орналасқан. Шартты түрде бұл жүйенің Z өсі тік жоғары, Х өсі оң жаққа, У өсі бақылауыштан шығатын бағытқа бағытталған деп есептеуге болады. Мах 2.5 проекциясының ортографикалық терезелері – аумақты координаталар жүйесінің қатысына байланысты Тор (төбесінен қарағандағы түрі), Front (алдынан қарағандағы түрі), Left (сол жағынан қарағандағы түрі) т.б деп аталған. Мах жүктелгеннен кейін проекция терезелерінде көрінетін координаталар – бұл аумақты координаталар жүйесіне сәйкес келетін жазықтықтың торы.

Аумақты жүйенің координаталық жазықтықтары бастапқы координаталық тордың (home grids) атымен аталады. Мах аумақты координаталар жүйенің жазықтығынан қандай да болсын бұрышпен орналаса алатын қосымша объект - тор (Grid Objects) жасауға мүмкіндік береді. Мұнда Мах объект торлардың координатты жазықтығына параллель болатын, жазықтықтағы объектілер көрінісінің ортографикалық проекциясын құруға мүмкіндік береді.

Мах 5 проекция терезелерінің келесі типін қолдайды:

- Тор (төбесінен қарағандағы түрі), Front (алдынан қарағандағы түрі), Left (сол жағынан қарағандағы түрі), Back (артынан қарағандағы түрі), Right (оң жағынан қарағандағы түрі),Button (астынан қарағандағы түрі) - сәйкес аумақты координаталар жүйесінің жазықтығының параллель болатын, жазықтықтағы объектілердің ортографикалық проекциясының 6 терезесі.

- Perspective- (Перспектива) - орналысуын қолданушы өзгерте алатын нүктеден қарағанда көріністің түрін сипаттайтын, орталық проекция терезесі.

- Белгі қоятын съемкалық камера сызығына параллель болатын, жазықтықтағы көріністің орталық терезесі. Мұндай терезелер көріністі камераның орналасу нүктесінен көруге мүмкіндік береді және камераның атымен сәйкес аталады, яғни үнсіздік бойынша Camera # (камера #) мұнда # - камераның реттік нөмері (01,02 т.с.с).

- Жарықтың көзінің сәулесінің өсіне перпендикуляр болатын жазықтықтағы көріністің орталық проекциясының терезесі. Мұндай терезелер көріністің әр бағытталған жарықтың көзі орналасқан нүктеден көріністі көруге мүмкіндік береді және жарықтың көзіне сәйкес атпен аталады, яғни үнсіздік бойынша Spot # (Прожектор #) немесе Direct # (Бағытталған #) мұнда #- жарықтың көзінің реттік нөмері (01,02, т.с.с).

- User (арнайы түр) – көріністі қолданушы өзгерте алатын бұрышпен көрсететін, аксонометриялық проекция терезесі.

- Grid (Top) (Top(төбесінен қарағандағы тор)), Grid (Front) (Top (алдынан қарағандағы түрі)), Grid (Left) (Top(сол жағынан қарағандағы түрі)), Grid Back (Top (артынан қарағандағы түрі)), Grid Right (Top (оң жағынан қарағандағы түрі)), Grid Button (Top (астынан қарағандағы түрі)), Grid(Display Planes) (Top (жазықтықтарды көрсету))- объект - тор координаталар жүйесінің жазықтықтарына параллель болатын жазықтықтағы объектілер проекциясының 6 ортографикалық терезесі және Display бөлімінде таңдалған объект тор қосымша параметрлерінің жиыны болатын, объект тордың конструкциялық жазықтығын бейнелейтін терезе.

- Shape (Пішін)- ерекшелінген екі өлшемді объект пішіндердің жергілікті координаталық жүйесін Х,У жазығына параллель болатын жазықтықтағы ортографикалық проекцияның терезесі.

Проекцияның терезесі ретінде Мах типі қолдайтын терезелердің қандайы болса да болады. Проекцияның кез-келген терезесінде Track View (Терезелерді қөру) терезесі орналасуы мүмкін. Бұл көріністің анимациясын жөндеу кезінде ыңғайлы. Бұл жағдайда Track View (Терезелерді көру) терезесінде бір әрекетті орындау проекцияның белсенді терезесінің ауысуына әкеледі. Проекция терезесіне Track View (Терезелерді көру) терезесін орналастыру кезінде терезенің аты сәйкес келеді, проекция терезесінің менюін шақыру үшін Track View (Терезелерді көру) терезе тақтасының, тақтаның батырмаларына тиіспей, тақтаның бір бөлігіне курсорды апарып тышқанның оң жақ батырмасын шерту керек.

Проекция терезесін басқару құралдары. Олар бағдарлама терезесінің оң жақ төменгі бұрышында орналасқан: масштаб, барлық терезедегі масштаб, толық көрініс, барлық терезедегі толық көрініс, облыс масштабы, жылжыту (айналдыру), Бүктеу /Қалпына келтіру.

Құралдар тақтасы



Сурет 2 Стандартты тақтаның батырмалары

Команда тақтасы. МАХ-тың топтарымен жабдықталғандардың алты командалық тақтасы болады: Create (Жасау), Modify (Өзгерту), Hierarchy (Иерархия), Motion (Қозғалыс), Display (Дисплей) және Utility (Сервис). Қажетті командалық панелді жөндеу үшін сәйкес бөлікке басу керек.



Сурет 3 Команда тақтасының топтары

Әр командалық тақтаның негізгі бөлігі шиыршық аймағы болып табылады. Шиыршық (rollout) – құрамында байланысқан параметрлер тобы бар және ені шиыршық енімен тең келетін батырма түріндегі тақырыпшасы бар командалық тақтаның бөлігі.

Шиыршықтар тек командалық тақтаның құрамында ғана емес, сонымен қатар Material Editor (Материалдарды түзетуші), Render Scene (Визуализациялау) сияқты сұхбаттық терезелер қатарында қолданылады.

Мах 5 объектілерінің барлық типтеріне, Editable Spline (Түзелетін сплайн), Editable Mesh (Түзелетін тор) объектілерін қоспағанда, параметрлік, яғни жасау кезінде оларға объектінің орналасу координаталар, ұзындығы, биіктігі бойынша өлшемдері деген сияқты мінездемелік параметрлер жиыны беріледі. Бұл параметрлер өзгеруі мүмкін. Сондықтан объектілерді жасау кезінде жоғарғы дәлдікке міндетті түрде ұмытылу қажет емес.


Өзін - өзі бақылауға арналған тапсырмалар:

Қорғауға берілген реферат тақырыптары:

  1. Озық графиктік жүйелер. Open GL кітапханасы.

  2. Екі өлшемді кескіндерді құрастыру және түрлендіру.

  3. Қарапайым қисықтарды растрға жіктеу. Брезенхем алгоритмі.


Негізгі әдебиеттер /1/,

Қосымша әдебиеттер/5,6,8/.


Дәріс – 28,29,30. 3D max объектісінің классификациясы

Дәрістің мақсаты: 3D Studio Max бағдарламасының объектісінің классификациясын қарастыру.


^ Тақырып бойынша қарастырылатын сұрақтар:

1 3 өлшемді – графиканың геометриялық үлгіленуі

2 3D Studio Max бағдарламасының объектісінің түрлері

3 Үлгілену қасиеттерімен жұмыс


^ Дәрістің тезисі: Geometry (Геометрия) категориясының объектілері. Бұл категорияға үш өлшемді көріністің геометриялық үлгісін құруға арналған объектілер енеді және келесі түрге бөлінеді:

- Standard Primitives (Стандартты фигуралар) – геометриялық форманың үш өлшемді денелері. Оларға пареллелипед, сфера және тор жатады. Стандартты фигураларға тарихы түрде шүмегі, сабы және қақпағы бар шайнек жатады.

- Extended Primitives (Жақсартылған фигура)- бұл стандартты фигураларға қарағанда көп параметрлерімен сипатталатын және күрделі формасы бар үш өлшемді дене. Оларға пареллельпипед, көпбұрыштар жатады.

- Loft Object (Лофтинг объектісі) – бұл лофтинг әдісімен яғни берілген траектория бойынша қойылған тіреуіш кескінділері бойынша қапты құру жолымен жасалған үш өлшемді денелер.

- Patch Grids (Бөлшектер торы) – бұл формасын және қиысықты меңгеретін нүктелерді басқарумен реттеуге болатын Базье бөлшектерінен тұратын беттер.

- NURBS Surfaces (NURBS- беттер ) – формасы біртексіз рациональды В- сплайндармен (Non- Uniform Rational B-Splines- NURBS ) сипатталатын беттер. NURBS беттер типіне байланысты олар көрініс кеңістігінде берілген нүктелерінің барлығынан өтеді немесе оларды жатық түрде қисайтады. Мұндай беттер тірі және өлі табиғатқа тән күрделі объектілерді үлгілеуге ыңғайлы.

- Compound Objects (Құрама объектілер)- бұл екі немесе оданда көп қарапайым объектілерден құралған үш өлшемді денелер.

- Particle System (Бөлшектер жүйесі) – бұл шаң, қар, түтін немесе оттың жарығы сияқты табиғи объектілерді бейнелеуге арналған екі өлшемді немесе үш өлшемді бөлшектердің жиынының көздері. Көрініс бөлшектерді үлгілеу кезінде олардың көздері шартты белгілермен бейнеленеді.

- Doors (Есіктер) және Windows (Терезелер) – бұл есік, терезе сияқты әртүрлі типтегі күрделі архитектуралық элементтерді оңай үлгілеуге мүмкіндік беретін стандартты объектілердің жаңа түрлері.

Shapes (Пішіндер) категориясының объектілері. Бұл категорияға тұйықталған немесе ашық екі өлшемді фигураларды (сызықтық бір типі ғана үш өлшемді кеңістікте орналасады - бұл спириаль) құрайтын сызықтық әртүрлі типтері жатады. Формалар әртүрлі әдіспен үш өлшемді денеге айналатын дайындық ретінде қолданылады және келесі түрге бөлінеді:

- Splines (Сплайндар)- бұлар тікбұрыш, эллипс, немесе жұлдыз сондай-ақ мәтіндік символдарының контрлары сияқты стандартты екі өлшемді геометриялық фигуралар.

- NURBS Curves (NURBS- қисықтары) - бұл жатық және сынбайтын қисықтарды құратын сызықтар түрі. NURBS –қисықтар көрініс бетінде көрсетілген барлық нүктелерден өтеді немесе оларды жатық иеді.

Lights (Жарық көздері) және Cameras (Камералар) категорияларының объектілері. Бұл категорияларға съемкалық категориялар объективі арқылы көріністі бақылау үшін арналған. Көрініске жарық шашу көздері бейнелеуге арналған объектілер жатады. Камера және жарық көздері ерікті және көзделген болады.

Көзделген жарық және көзі мишеннің – жарық сәулесі немесе камераның көру сызығы көздеген нүктелік объект бар болуымен сипатталады.

Helpers (Көмекші объектілер) категориясының объектісі. Бұл категорияға көріністің нәтежесіндегі бейнесіне енбейтін және оны үлгілеу және анимациялау мәселерін жеңілдетуге арналған объектілер енеді. Қосымша объектілер келесі түрге бөлінеді:

- Standard (Стандарттық) – геометриялық үлгілерді анимациялау және жасау кезінде қосымша ретінде қолданылатын объектілер.

- Atmospheric Apparatus (Атмосфералық құралдану) – қоршаған орта әсерлері пайда болатын облыстарды жөндеуге арналған объектілер.

- Camera Match (Камера горизонты) – съемкалық камераның горизонтты сызықтарын көріністің фонының горизонтымен, үлгілерді суреттің фонында немесе бейнеклиптің кадрлерінде көрсету кезінде сәйкестендіреді.

- VRML 1.0/VRBL және VRML97 - шынайы виртуалды тілдер форматын экспорттауға арналған, үш өлшемді көріністі үлгілеуде қолданылатын объектілер.

Space Warps (Көлемді диформациялар) категориясының объектілері. Бұл категорияға, геометриялық үлгілердің диформациялау факторы әсеріндегі кеңістіктерден жылжу кезіндегі, диформациялық әсерге ұшырауын бейнелеуге арналған объектілер жатады.

Көлемді диформациялар келесі түрге бөлінеді:

- Geometric / Deformable (Диформацияланатын геометрия) және Modіfier-Based (Модификаторлар базасы) өздерімен байланысқан геометриялық объектілерді деформациялайды.

- Particles & Dynamics (Бөлшектер және динамика) олар мен байланысқан жеке бөлшектер жүйесіне күштік әсер көрсетеді, сондай-ақ объектіге көрсетілген салмақ және жел күшін бейнелеуде қолданылады.

Systems (Жүйелер) категориясының объектілері. Жүйенің әр типі өзара байланысқан, параметрлер жиыны бар, анимациялар жүйесін қамтамасыз ететін объектілер түрінде беріледі. Бұл категория басында қосымша бағдарламалық модуль түрінде жасалынған объектілерді жүйеге енгізуге арналған. Мах 5 комплексіне жүйенің 3 типі енеді:

- Bones (Сүйектер) – түзу немесе кері книматика әдістерінің анимациясында қолданатың және қанқаның сүйектеріне ұқсас, рычактардың иерархиялық байланысқан тізбектерін жасауға мүмкіндік береді.

- Sunlight (Күннің жарығы) – үлгіленіп отырған көріністегі күннің жарығын бейнелейтін жарықтың параллельді сәулелерінің көзін жасауға сондай-ақ графикалық орналасуды, жылдың мезгілін және тәулікті ескере отырып күннің қимылын жасауға мүмкіндік береді.


Өзін - өзі бақылауға арналған тапсырмалар:

Қорғауға берілген реферат тақырыптары:

  1. Сплайн негізінде үлгілену

  2. Параметрлі үлгілену

  3. Көп бұрыштар немесе тор негізінде үлгіленуі


Негізгі әдебиеттер /1/,

Қосымша әдебиеттер/5,6,8/.








Скачати 342.56 Kb.
Дата конвертації23.10.2013
Розмір342.56 Kb.
ТипДокументы
Додайте кнопку на своєму сайті:
uad.exdat.com


База даних захищена авторським правом ©exdat 2000-2012
При копировании материала укажите ссылку
звернутися до адміністрації
Документи